Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Banned
    Join Date
    Jun 2009
    Posts
    2,446

    Team Fortress 2 Issues with Windows 7 (Common Fixes)

    As with all of my topics it's Vital you read ALL of the post, not just particular sections, however you can skip the next block of text if you want.

    So rather then have to explain to everyone the various fixes that have worked for some people and not for others I'll simply post the majority of fixes below, keep in mind these aren't guaranteed to fix your issues with Team Fortress 2 and Windows 7 but you have a better chance then when you do nothing.

    If you're planning on upgrading to Windows 7 I suggest buying the Retail Version, most of the problems Windows 7 is having with Source Engine games are due to unpatched issues in the torrented versions. Keep in mind if you're using a torrented version that's not up to date with retail versions I cannot offer you any support.


    Use At Your Own Risk
    Some of these fixes may work for both Torrent and Retail W7 Users, they may also work for other games, I take no responsibility for Damaged Hardware, Software or yourself due to any of the fixes I've posted below. If something should go wrong though feel free to blame Myspace, all problems can be related to Myspace.





    Disable Aero Theme
    Team Fortress 2 by default doesn't disable the Aero theme for itself like it did in Vista, this is one of the first fixes I recommend you try, it's worked for about 75% of users that are having issues with Team Fortress 2 in Windowed Mode. To do this follow the steps below, I won't be using images like I do in a lot of my other Guides / Help topics just because I lack the retail version of Windows 7 on a working PC. (This has also increased some Windows 7 users Performance when playing Team Fortress 2)

    Steps


    1. Navigate to HL2.exe in your Team Fortress 2 Directory [X:\Games\Steam\steamapps\username\team fortress 2\hl2.exe]
    2. Right click on HL2.exe and select "Properties"
    3. Select the "Compatibility Tab"
    4. Disable the following by clicking on their boxes "Disable Themes or Composition"


    Note: If TF2 Fails to start at all after this fix it's recommended you simply uncheck the boxes you checked previously, this will undo anything you've just done so you won't actually experience any issues because of this fix.





    Background Audio is Extremely Low when playing Team Fortress 2
    It's a feature of Windows 7, when playing Team Fortress 2 Windows 7 lowers all other sounds in the background like Ventrilo, Windows Media Player, iTunes, etc. This shouldn't be happening as it's only intended for Phone Calls but on some systems it registers peoples voices within TF2 as a phone call and reduces the sound volume in the background to 20% of it's normal volume.

    Steps


    1. Go into your Audio Properties (Control Panel --> Sound or Audio, etc)
    2. When in your Audio Properties go into the "Communications Tab" and you'll see a drop box with this sentence above it.
    3. "When Windows detects communications activity" make sure the Drop Box is set to 0%.



    Note:
    Reverse the steps above if you experience issues, the default percentage is 80%.









    Upgrading Old / Release Video Drivers

    Hopefully you all know how to do this, Windows 7 by default at launch didn't install the most up-to-date Windows 7 Video Card Drivers, in order to get the updated versions of your drivers view the steps below.

    Steps


    1. Uninstall your Video Drivers, to do this go into Add / Remove Programs and you know how to do the rest (if you don't left click on the Video Driver which will be called either the ATI Display Driver or I nVidia Display Driver or nVidia Uninstall Utility and follow the steps to uninstall)
    2. Now that your Video Card drivers have been uninstalled you might as well download the new drivers from the proper website, Click HERE for ATI's Website, Click HERE for nVidia's Website.
    3. After your Driver has finished downloading you'll need to Restart your Computer, once your system is reset proceed to Install the driver, that's it.


    Note: in ATI's case it's always best to have the latest driver, in nvidia's case remember what Driver you had installed before if you need to rollback to an older driver due to issues.





    Team Fortress 2 shows a normal ping but I or others experience
    LAG!

    There's an issue with Multiple Core rendering and Windows 7, the only known fix for it is disabling multiple core rendering, which hurts FPS (Frames Per Second). You have two choices, live with the Lag / Spikes or disable multiple core rendering and lose FPS.

    Steps



    1. Start Team Fortress 2 (assuming it works)
    2. Left-Click on Options
    3. Left-Click on the Video Tab
    4. Disable multiple core rendering from the Advanced Tab, see the picture below for the location of this Command.



    Note: This doesn't fix Loss or Choke, if you're receiving Loss it's generally your ISP's fault (Test your line at Pingtest) if you're experiencing Choke anything between 1 - 9 is fine, most people experience choke when in the Respawn, Opening Doors, etc. If however you experience choke whenever you Shoot, Walk, Jump, etc and it's above 10 you can try various rate adjustments)


    Picture provided by WildFire's friend, aka WildFire cause he has no friends





    Help my TF2 FPS is lower then it was in XP!
    I've had so many PM's, EMails and Steam Messages about this, when upgrading to a new operating system never expect any increased performance, in fact expect decreased performance (unless moving from say, Windows 95 to Windows XP, Vista to 7, Windows to Ubuntu, etc)

    There is no fix for this, it's not an issue, it's one of the reasons I'm still on XP, in terms of performance for DirectX 9.0 titles nothing will EVER beat Windows XP due to the low amount of Memory Usage by the Operating System which generally leaves more resources open for Team Fortress 2.

    So in other words, XP > Vista + W7.





    Team Fortress 2 fails to open, crashes upon opening, crashes after a large amount of playtime
    There's only a bunch of little fixes to try and fix this issue, most of the time these combined fixes work but for a handful of people nothing has helped them get Team Fortress 2 and other Source Engine Games working on there W7 Computer.

    Fixes



    1. Uninstall Norton, AVG, Zone Alarm, Comodo Anti-Virus or any other Firewall / Anti-Malware / Virus programs. These programs use a large amount of your Paged Pool Memory and just disabling them doesn't fix this, in order to make sure your Paged Pool Memory is completely free you'll need to Uninstall these programs. Keep in mind if this doesn't fix the issue you can always INSTALL these programs again.
    2. Disable / Close (Or Uninstall) the following Programs, XFire, MSN Messenger, AOL, AIM, ICQ, Logitech G15 Drivers + all of the "Programs" being used by the G15.
    3. Available to W7 Professional / Ultimate users is the ability to use Windows XP compatibility mode, try this if Team Fortress 2 fails to work after all the fixes above.
    4. Re-install DirectX 9.0 even if your Hardware supports DirectX 10 - 11+ (Download Here)



    Conclusion
    Those are some of the more common fixes for Team Fortress 2, hopefully this helps some of you, if for some reason you have another fix that I didn't list above that has worked for you to get Team Fortress 2 or another popular game working let me know and I'll add it to the list.

    Sincerely,
    WildFire
    Last edited by 1up_dave; 12-01-2009 at 04:57 PM.

  2. #2
    Monster's Avatar
    Join Date
    Nov 2008
    Location
    Central FL, USA
    Posts
    289
    • Computer Specs
      • Motherboard: EVGA x58 SLI
      • Processor: Intel Core i7 950 3.06GHz
      • Memory: Corsair 6GB DDR3 1600MHz
      • Video Card # 1: ATI Radeon HD 5870
      • Hard Drive # 1: Western Digital 750GB
      • Optical Drive # 1: LG 5x Blu-Ray Reader/x16 DVD Burner
      • Power Supply: Corsair 850HX
      • Monitor: Samsung P2570 24.6"
      • Operating System: Windows 7
    Gold Donor
    Steam ID: iomonster HLSTATS ID: 5887
    Nice post, WildFire! Thanks for taking the time to do this. It would've helped me when I was trying to figure it out, so I'm sure it'll help plenty of others.


  3. #3
    Scottstimo's Avatar
    Join Date
    Jan 2009
    Location
    California
    Posts
    777
    Blog Entries
    1
    Images
    1
    • Computer Specs
      • Case: NZXT Apollo Black SECC Steel Chassis ATX Mid Tower Computer Case
      • Motherboard: MSI P55M-GD45 LGA 1156 Intel P55 Micro ATX Intel Motherboard
      • Processor: Intel Core i7-860 Lynnfield 2.8GHz LGA 1156 95W Quad-Core Processor BX80605I7860
      • Memory: 2x G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) Desktop Memory
      • Video Card # 1: Asus 560 Ti TOP
      • Hard Drive # 1: HITACHI Deskstar HD31000 IDK/7K (0S00163) 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive
      • Optical Drive # 1: ASUS Black IDE DVD-ROM Drive Model DVD-E818A4/BLK/B/GEN
      • Power Supply: Antec EarthWatts EA650 650W Continuous Power ATX12V Ver.2.2 / EPS12V version 2.91 SLI Certified Cros
      • Monitor: Gateway 24" 1080p Monitor
      • Operating System: Microsoft Windows 7 Home Premium 64-bit 1-Pack for System Builders - OEM
    Bronze Donor
    New Server Contributor
    Steam ID: http://steamcommunity.com/id/scottstimo
    I have a not-related-to-this-post-but-still-a-problem-problem. Whenever I access the iO site on one of my school's laptops (running one of the more recent Mac OSX builds), when I look under WildFire's name (to the left of the post), it only says that (s)he is an "iO TF2 MEMBER", and nothing more.

    Can someone explain to me why (s)he doesn't have a "bar thing" that displays something along the lines of "OFFICIAL iO HELPER"

    Luls. Great posts, WildFire.

  4. #4
    elf6c's Avatar
    Join Date
    Jun 2009
    Location
    Virginia
    Posts
    653
    Gold Donor
    New Server Contributor
    Thanks Wildfire +rep!



  5. #5
    Banned
    Join Date
    Jun 2009
    Posts
    2,446
    I think the reason I don't have a Title like that is because the iO Admin, Staff and SrAdmin team is made up of 98% Americans, being Canadian I'm not trusted with the Family Secrets just yet, give it a few more years and maybe I'll get something like "iO's Bitch".

    Oh and before I forget, also because I'm an asshole,
    WildFire

    PS: Kinda losing my voice, people in Ventrilo are now safe and able to have uninterrupted conversations!
    Last edited by WildFire; 11-10-2009 at 05:21 PM.

  6. #6
    McChicken's Avatar
    Join Date
    Mar 2009
    Location
    South Portland, Maine
    Posts
    2,267
    Images
    3
    • Computer Specs
      • Case: Antec 300 series
      • Motherboard: MSI 970A-G46
      • Processor: AMD FX-6200 @ 3.8
      • Memory: CORSAIR XMS3 8GB
      • Video Card # 1: XFX 7950 DD 3gig
      • Hard Drive # 1: WD Blue 300g 7200RPM
      • Hard Drive # 2: Western Digital My Book 3.0 1TB USB 3.0 External Hard Drive
      • Optical Drive # 1: BD-Rom Drive
      • Optical Drive # 2: DVD-CDRW
      • Power Supply: CORSAIR CMPSU-850TX 850W
      • Sound Card: Realtek High definition Audio
      • Monitor: 19 HD widescreen @ 1440x900
      • Operating System: Windows 7 64-Bit
    Gold Donor
    Thanks WildFire! Still working to getting it solved... right now i cant even get into steam
    Donate to OUR community: http://iogaming.net/donate




  7. #7
    McChicken's Avatar
    Join Date
    Mar 2009
    Location
    South Portland, Maine
    Posts
    2,267
    Images
    3
    • Computer Specs
      • Case: Antec 300 series
      • Motherboard: MSI 970A-G46
      • Processor: AMD FX-6200 @ 3.8
      • Memory: CORSAIR XMS3 8GB
      • Video Card # 1: XFX 7950 DD 3gig
      • Hard Drive # 1: WD Blue 300g 7200RPM
      • Hard Drive # 2: Western Digital My Book 3.0 1TB USB 3.0 External Hard Drive
      • Optical Drive # 1: BD-Rom Drive
      • Optical Drive # 2: DVD-CDRW
      • Power Supply: CORSAIR CMPSU-850TX 850W
      • Sound Card: Realtek High definition Audio
      • Monitor: 19 HD widescreen @ 1440x900
      • Operating System: Windows 7 64-Bit
    Gold Donor
    Disable Aero Theme
    Team Fortress 2 by default doesn't disable the Aero theme for itself like it did in Vista, this is one of the first fixes I recommend you try, it's worked for about 75% of users that are having issues with Team Fortress 2 in Windowed Mode. To do this follow the steps below, I won't be using images like I do in a lot of my other Guides / Help topics just because I lack the retail version of Windows 7 on a working PC. (This has also increased some Windows 7 users Performance when playing Team Fortress 2)

    Steps

    1. Navigate to HL2.exe in your Team Fortress 2 Directory [X:\Games\Steam\steamapps\username\team fortress 2\hl2.exe]
    2. Right click on HL2.exe and select "Properties"
    3. Select the "Compatibility Tab"
    4. Disable the following by clicking on their boxes "Disable Themes or Composition"

    Note: If TF2 Fails to start at all after this fix it's recommended you simply uncheck the boxes you checked previously, this will undo anything you've just done so you won't actually experience any issues because of this fix.


    Trying this right now...
    Donate to OUR community: http://iogaming.net/donate




  8. #8
    McChicken's Avatar
    Join Date
    Mar 2009
    Location
    South Portland, Maine
    Posts
    2,267
    Images
    3
    • Computer Specs
      • Case: Antec 300 series
      • Motherboard: MSI 970A-G46
      • Processor: AMD FX-6200 @ 3.8
      • Memory: CORSAIR XMS3 8GB
      • Video Card # 1: XFX 7950 DD 3gig
      • Hard Drive # 1: WD Blue 300g 7200RPM
      • Hard Drive # 2: Western Digital My Book 3.0 1TB USB 3.0 External Hard Drive
      • Optical Drive # 1: BD-Rom Drive
      • Optical Drive # 2: DVD-CDRW
      • Power Supply: CORSAIR CMPSU-850TX 850W
      • Sound Card: Realtek High definition Audio
      • Monitor: 19 HD widescreen @ 1440x900
      • Operating System: Windows 7 64-Bit
    Gold Donor
    nvm i cant even open steam right now
    Donate to OUR community: http://iogaming.net/donate




  9. #9
    Banned
    Join Date
    Jun 2009
    Posts
    2,446
    For your issue try Starting Steam, when it doesn't open press "Control + Alt + Delete" to open the Task Manager, find "Steam.exe" and press "Delete" (not backspace) on this process, this will kill the process and end Steam.

    Now there's 2 options here, try them both.

    1) Re-Start steam normally, it should either Update or Go straight through a normal Launch, if this happens your problem is solved, if however this doesn't work try the below method, it kinda tricks W7.

    2) Disconnect yourself from the Internet (Unplug your PC's Ethernet Cable or Disconnect from your Wireless Network).

    Start Steam, when Steam Starts it will ask you to go into Offline Mode, when this pops up don't press anything instead reconnect your Ethernet Cable / Wireless network and press Retry, if it fails to start again I'd recommend opening up a Technical Support Question with Steam.

    Also if you're using 64-bit you could try Uninstalling Steam (Backing up the GCF's so you don't have to re-download them) and creating a folder called "Steam" in the C: Folder (or whatever your Storage Drive is), install steam in this folder and see if it'll boot. This works for some people but might not work for your issue, worth a shot though.

    I'm making hotdogs,
    WildFire

  10. #10
    McChicken's Avatar
    Join Date
    Mar 2009
    Location
    South Portland, Maine
    Posts
    2,267
    Images
    3
    • Computer Specs
      • Case: Antec 300 series
      • Motherboard: MSI 970A-G46
      • Processor: AMD FX-6200 @ 3.8
      • Memory: CORSAIR XMS3 8GB
      • Video Card # 1: XFX 7950 DD 3gig
      • Hard Drive # 1: WD Blue 300g 7200RPM
      • Hard Drive # 2: Western Digital My Book 3.0 1TB USB 3.0 External Hard Drive
      • Optical Drive # 1: BD-Rom Drive
      • Optical Drive # 2: DVD-CDRW
      • Power Supply: CORSAIR CMPSU-850TX 850W
      • Sound Card: Realtek High definition Audio
      • Monitor: 19 HD widescreen @ 1440x900
      • Operating System: Windows 7 64-Bit
    Gold Donor
    Quote Originally Posted by WildFire View Post
    For your issue try Starting Steam, when it doesn't open press "Control + Alt + Delete" to open the Task Manager, find "Steam.exe" and press "Delete" (not backspace) on this process, this will kill the process and end Steam.

    Now there's 2 options here, try them both.

    1) Re-Start steam normally, it should either Update or Go straight through a normal Launch, if this happens your problem is solved, if however this doesn't work try the below method, it kinda tricks W7.

    2) Disconnect yourself from the Internet (Unplug your PC's Ethernet Cable or Disconnect from your Wireless Network).

    Start Steam, when Steam Starts it will ask you to go into Offline Mode, when this pops up don't press anything instead reconnect your Ethernet Cable / Wireless network and press Retry, if it fails to start again I'd recommend opening up a Technical Support Question with Steam.

    Also if you're using 64-bit you could try Uninstalling Steam (Backing up the GCF's so you don't have to re-download them) and creating a folder called "Steam" in the C: Folder (or whatever your Storage Drive is), install steam in this folder and see if it'll boot. This works for some people but might not work for your issue, worth a shot though.

    I'm making hotdogs,
    WildFire
    Thanks for all the help today Wildfire

    ive done number 1 a ton of times.... no error or anything...nothing happens at all

    im going to try reinstalling everything right now and ill keep you posted
    Donate to OUR community: http://iogaming.net/donate




  11. #11
    Banned
    Join Date
    Jun 2009
    Posts
    2,446
    Forgot to mention, after you uninstall steam actually do a Restart or it'll keep the old Registry Keys.

  12. #12
    Yaoi's Avatar
    Join Date
    Nov 2009
    Location
    Canada
    Posts
    125
    Steam ID: http://steamcommunity.com/profiles/76561197991712773?

    Thumbs up

    I have been thinking of getting Windows 7 so this is incredibly useful, thank you.

  13. #13
    Duki's Avatar
    Join Date
    Aug 2009
    Location
    Panama City, FL
    Posts
    40
    • Computer Specs
      • Motherboard: EVGA 780i
      • Processor: Intel Quad 2.66
      • Memory: 4gb DDR2
      • Video Card # 1: nvidia gtx 285
      • Hard Drive # 1: WD 300gb 7200rpm
      • Hard Drive # 2: Hitachi Raptor 10000rpm 120gb
      • Power Supply: Thermaltake 750w
      • Monitor: Samsung syncmaster T220
      • Operating System: Windows 7 HP
    Bronze Donor
    Steam ID: ericnebel_2004@hotmail.com
    tried the ones relevant and nothing. I use retail W7 home prem edition and whenever I load tf2 it takes forever (1-5min) to get to the valve screen and another few minutes to actually load the menu so you can join a server. I have no freaking idea why it's doing this and nothing I've tried is fixing it. plz r help meeeee!



  14. #14
    Banned
    Join Date
    Jun 2009
    Posts
    2,446
    Quote Originally Posted by Duki View Post
    tried the ones relevant and nothing. I use retail W7 home prem edition and whenever I load tf2 it takes forever (1-5min) to get to the valve screen and another few minutes to actually load the menu so you can join a server. I have no freaking idea why it's doing this and nothing I've tried is fixing it. plz r help meeeee!
    Add -novid to the Command Line for Team Fortress 2, Right click on TF2 in Steam, Select Properties, Set Launch Options, the below is what you want.

    -novid -noborder -hs

    Copy it exactly how I wrote it (don't need -noborder or -hs, I'm tpo lazy to press Backspace), that should skip the whole Valve Video part and move directly to the game.
    Last edited by WildFire; 11-10-2009 at 07:37 PM.

  15. #15
    Duki's Avatar
    Join Date
    Aug 2009
    Location
    Panama City, FL
    Posts
    40
    • Computer Specs
      • Motherboard: EVGA 780i
      • Processor: Intel Quad 2.66
      • Memory: 4gb DDR2
      • Video Card # 1: nvidia gtx 285
      • Hard Drive # 1: WD 300gb 7200rpm
      • Hard Drive # 2: Hitachi Raptor 10000rpm 120gb
      • Power Supply: Thermaltake 750w
      • Monitor: Samsung syncmaster T220
      • Operating System: Windows 7 HP
    Bronze Donor
    Steam ID: ericnebel_2004@hotmail.com
    Quote Originally Posted by WildFire View Post
    Add -novid to the Command Line for Team Fortress 2, Right click on TF2 in Steam, Select Properties, Set Launch Options, the below is what you want.

    -novid -noborder -hs

    Copy it exactly how I wrote it (don't need -noborder or -hs, I'm tpo lazy to press Backspace), that should skip the whole Valve Video part and move directly to the game.
    Well...that didnt help. It still takes the game about 5 minutes from the time I click the icon to actually launch the game. My processor is thinking but nothing happens and the computer freezes or gets REAAAAAAL slow before it finally launches the damn game.



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •